最代码
shyleo的gravatar头像
shyleo2016-12-17 21:39:13
eclipse从高版本JDK换成低版本JDK报的一些错误总结

①:Stanford Parser demo错误:Unsupported major.minor version 52.0 error

②:运行时:Project facet Java version 1.8 not supported

本人电脑原先用的jdk1.8,后来在学习javaee各框架整合时,发现用jdk1.8比较蛋疼,后改回了1.7版本。改了后运行项目发现了以上一些问题。

出现问题原因:JDK版本不一致。

​我是这样解决的:

首先,看一下项目 java build path 中的libraries有没有错误

eclipse从高版本JDK换成低版本JDK报的一些错误总结

然后。右键点击项目->properties->Java Compiler->....如图

eclipse从高版本JDK换成低版本JDK报的一些错误总结

最后,右键点击项目->properties->Project  Facets->....如图

eclipse从高版本JDK换成低版本JDK报的一些错误总结

最后,问题就迎刃而解了smiley


打赏

分享到:

最近浏览
xysoft2017年12月25日
最代码贡献等级说明
c8417139420162017年10月17日
暂无贡献等级
2037785132017年9月13日
最代码贡献等级说明
q28238652017年9月7日
暂无贡献等级
junwuxie2017年9月4日
最代码贡献等级说明
a111111112017年9月1日
暂无贡献等级
千里草2017年7月21日
暂无贡献等级
啊啊啊啊1112017年7月4日
暂无贡献等级
yangsiqin3332017年6月17日
暂无贡献等级
顶部客服微信二维码底部
>扫描二维码关注最代码为好友扫描二维码关注最代码为好友